Sintoma:

Ao tentar reiniciar o Apache, o seguinte erro pode aparecer: /etc/apache2/conf.d/modsec/modsec2.cpanel.conf: Could not open configuration file /etc/apache2/conf.d/modsec_vendor_configs/imunify360-full-apache/006_i360_custom.conf

Esse erro indica que um dos arquivos de configuração de regras do Imunify360 está ausente ou corrompido — normalmente o 006_i360_custom.conf.

Causa:

Esse tipo de falha ocorre quando o conjunto de regras do Imunify360 para o ModSecurity foi parcialmente removido ou está com erro de integridade. Isso pode acontecer após atualizações mal sucedidas, mudanças manuais ou conflitos internos.


Solução:

Para corrigir, vamos reinstalar corretamente o conjunto de regras do Imunify360 no Apache, limpando qualquer configuração corrompida. Siga o passo a passo:

  1. Verifique os fornecedores de regras ativos no servidor: whmapi1 modsec_get_vendors | grep -i id_do_fornecedor | uniq -u
  2. Desative as configurações do fornecedor problemático: /scripts/modsec_vendor disable-configs imunify360-full-apache imunify360-full-apache
  3. Remova o fornecedor de regras Imunify360 atual: /scripts/modsec_vendor remove imunify360-full-apache
  4. Adicione novamente o fornecedor do Imunify360: whmapi1 modsec_add_vendor url=https://files.imunify360.com/static/modsec/v2/meta_imunify360-full-apache.yaml
  5. Ative o fornecedor de regras: whmapi1 modsec_enable_vendor vendor_id=imunify360-full-apache
  6. Reconstrua o arquivo de configuração do Apache: /scripts/rebuildhttpdconf
  7. Reinicie o serviço do Apache: systemctl reiniciar httpd

Observação

⚠️ Sempre que for realizar alterações nas regras do ModSecurity, recomendamos fazer isso fora do horário de pico dos seus clientes e ter um snapshot ou backup disponível.

 

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